Go to Gallery           Register for MyTrainz | Login to MyTrainz

TANE SP2 HF1 Beta Update Aug 09, 2017

By Tony_Hilliam, August 09 2017

We're now ready to release the next update for our Beta Testers. This will patch from 88978 to 89139 using the Beta Stream.

This build is looking solid, and based upon feedback over the next week, we'll look to getting this build out to a much wider beta group and then on to a public release after that.

Beta Testers - if you have experienced a crash in past versions, please retest in this version and also let us know if the crash is resolved by commenting in this forum thread. 

Changelist for Update to Build 89139

  • Update Surveyor to set the session as discardable by default, if the session is new
  • Fixed - Get Vertex Height tool and several others disabled by Fill Grid
  • Fixed - Plateau tool using incorrect height value
  • Fixed - Multi-board copy paste condenses objects onto a single baseboard
  • Fixed - Named objects are not brought across in map merge
  • Fixed - In cab keys stop working once outside the cab
  • Fixed - "InitBuffers: vertexBuffer is NULL"
  • Fixed - Adding assets to a picklist doesn't flag TAD as modified
  • Fixed - Undoing spline point deletion triggers NamedObjectTable command failure
  • Fixed - Test Track - script errors
  • Fixed - Adding an '&' in a picklist name causes TANE to "Not Respond"
  • Fixed - Crash when selecting "Get Assets from the World" in Add Random scenery tool
  • Fixed - T2AttachmentPointAnimated::Update> not attached to scene; can't update yet.
  • Fixed - Crash related to nav points
  • Fixed - Adding assets to a picklist doesn't flag TAD as modified
  • Fixed - NamedObjectTable assertion during merge route
  • Fixed - spurious validation errors
  • Fixed - AJS Traffic Controller <kuid2:122285:1159:3> leaves arrows behind after deleting
  • Fixed - Focus camera rule not working
  • Fixed - Game exit shutdown crash (sound related)
  • Fixed - "TANE has stopped working" when merging
  • Fixed - Driver Setup rule in sessions created pre-88876 don't setup the player driver
  • Fix several other Driver setup issues
  • Fixed - Junction kit (right) is faulty
  • Fixed - “WaitForCameraViewMode : Message Queue Overflow"
  • Clarify "WorldCoordinate::Normalise> internal failure" assertion message